• Changes to Server go to this thread http://overzealousgamers.com/threads/etpub-changelog.6665/
  • server back up

My video (from work) relating to "lag" issue

#1
Well I went on OZ server from work and put together a short demo of how the gameplay looks and trying to locate those so called spikes that perhaps relate to LAG issues and/or server setting.

The server had about 10 players in total and the map is Goldrush. I get a ping of ~20-30. You need to enable the lagometer (/cg_lagometer 1) via the command promt in ET. Link to file is here (http://www.mediafire.com/?sharekey=4f65 ... f6e8ebb871) and via the forums upload.

Basically the red spikes indicate loss of connection and I do see them but at random times. Considering I have by far the best connection (from work) those random red spikes on the lagometer cannot come from my end but server end I would suspect. I had /rate 25000, maxfps of 76 and maxpackets at default (30 i think). If you consider that the red spikes are from server end, when the player numbers increase and obviously connection speeds from everyone are lower than that of mine at work (6-7MB/sec down and 1.5MB/sec up)....I would not be suprised why people call LAG all the time.

Next thursday I will come on (from work) again but closer to 7pm. Fill the server up and I will test it out again with various settings.

What you guys think? I still think server side is playing up but due to connection issues between majority of players and server (and at random times) this causes server to lose key pakcets when sending information and therefore lag spikes. I've seen people call "lag' at the same time before and it cant be a coincidence.

Just my 2c on the ongoing issue lol.
 

Attachments

SkankyMoe

Well-Known Member
#3
PLEASE POST TRACERT

FIRST GUESS ITS GOING TO BE A FIREWALL / ROUTING / NAT / PORT FORWARDING RELATED ISSUE.

PS. IF YOU DONT WANT TO POST FULL TRACERT FOR ALL TO SEE, SEND IT TO ME ON MSN
 

Lestat

Well-Known Member
#4
I still say OZ is being undersold on the bandwidth side of thing's 100mbit more like 10mbit ( and shared for other game server's)

ptgn,ogn,node all them had full bandwidth because they Sold it.Where as OZ is being sold bandwidth by a 3rd party and who know's it may be a 100mbit connect,But who else is sharing that pool???
 

SkankyMoe

Well-Known Member
#5
Lestat said:
I still say OZ is being undersold on the bandwidth side of thing's 100mbit more like 10mbit ( and shared for other game server's)

ptgn,ogn,node all them had full bandwidth because they Sold it.Where as OZ is being sold bandwidth by a 3rd party and who know's it may be a 100mbit connect,But who else is sharing that pool???
I DOUBT IT, I JUST RAN ET IN WINDOW MODE, SENT YOU SOME MESSAGES WHILE DOING A FTP TRANSFER STRAIGHT OF THE GAME SERVER LIVE, HAD LAGO RUNNING, TAB DOWN,
SHOWING EVERYONES PINGS AND NO ONES PINGS FLINCHED AT ALL, THE SERVER HAD MORE THAN ENOUGH BANDWIDTH ON TAP, AS WELL THE HOST PROVIDER.
Transferred: rhine_bridge3.pk3 21.07 MB in 36.73 seconds (587.2 KB/s)
I USED DESKTOP RECORDING SOFTWARE, I WAS GOING TO POST THE VIDEO, BUT MY NATIVE RES BEING 1920X1080 ENDED UP BEING FRELLING MASSIVE, EVEN CONVERTING TO DIVX/XVID ITS STILL OVER 200 MEG
SO I RECON WE CAN PUT THAT THEORY TO REST, OH AND IVE UPLOADED JUST OVER 300MB OF NEW MAPS WHILE PLAYING AND SERVER LOADED AND IT HASNT CAUSED ANY PROBLEMS ALONG THE WAY EITHER.
 

Black Racoon

Head Poncho
Staff member
#6
SkankyMoe said:
Lestat said:
I still say OZ is being undersold on the bandwidth side of thing's 100mbit more like 10mbit ( and shared for other game server's)

ptgn,ogn,node all them had full bandwidth because they Sold it.Where as OZ is being sold bandwidth by a 3rd party and who know's it may be a 100mbit connect,But who else is sharing that pool???
I DOUBT IT, I JUST RAN ET IN WINDOW MODE, SENT YOU SOME MESSAGES WHILE DOING A FTP TRANSFER STRAIGHT OF THE GAME SERVER LIVE, HAD LAGO RUNNING, TAB DOWN,
SHOWING EVERYONES PINGS AND NO ONES PINGS FLINCHED AT ALL, THE SERVER HAD MORE THAN ENOUGH BANDWIDTH ON TAP, AS WELL THE HOST PROVIDER.
Transferred: rhine_bridge3.pk3 21.07 MB in 36.73 seconds (587.2 KB/s)
I USED DESKTOP RECORDING SOFTWARE, I WAS GOING TO POST THE VIDEO, BUT MY NATIVE RES BEING 1920X1080 ENDED UP BEING FRELLING MASSIVE, EVEN CONVERTING TO DIVX/XVID ITS STILL OVER 200 MEG
SO I RECON WE CAN PUT THAT THEORY TO REST, OH AND IVE UPLOADED JUST OVER 300MB OF NEW MAPS WHILE PLAYING AND SERVER LOADED AND IT HASNT CAUSED ANY PROBLEMS ALONG THE WAY EITHER.
I completely agree with skanky, we are not being ripped off, the problem does not lie with our host directly, may be due to connection TO the server from them, for some, where others may have hardware or net related issues. Not everyone lags on the server. And its certainly not to do with the hardware specs as mythologized before by some.

Cheers, BR
 

Black Racoon

Head Poncho
Staff member
#7
We have moved server now to more powerful machines, so if there was a problem on the last one hopefully the moved corrected it :).


Cheers, BR
 
#8
Hi all you may remember me from ptgn as head games admin for there et servers..

I played on the et server sat 31st after a invite from horus and it was smooth as,,not taking my set up into account with a what ever i wanted with fps but the ping was very nice of up to 30 ,smooth game play so from my end here in brissy thumbs up to a very playable et server..i also enjoyed playing it again after being away a while :)

Regards Riff
 

Joke :D

Well-Known Member
#9
Riff_Raff said:
Hi all you may remember me from ptgn as head games admin for there et servers..

I played on the et server sat 31st after a invite from horus and it was smooth as,,not taking my set up into account with a what ever i wanted with fps but the ping was very nice of up to 30 ,smooth game play so from my end here in brissy thumbs up to a very playable et server..i also enjoyed playing it again after being away a while :)

Regards Riff
woah blast form the past



and yeah same here too, very little lag and settings are good :)
 
Top